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Súradnicový systém S-JTSK[JTSK03] v QGIS 
 

V aplikácii QGIS (od verzie 3.10) je už zadefinovaný geodetický referenčný súradnicový systém  

S-JTSK[JTSK03] (kód EPSG:8351) spolu s jeho projekciami S-JTSK [JTSK03] / Krovak (kód EPSG:8352) 

a S-JTSK [JTSK03] / Krovak East North (kód EPSG:8353), ktorá sa používa v GIS aplikáciách. V návode 

je popísaný postup nastavenia súradnicových systémov a transformácií používaných na území 

Slovenska. Návod platí pre QGIS verzia 3.20.0 (19.6.2021) a novšie, ktoré je možné bezplatne 

stiahnuť na stránke https://qgis.org/en/site/. Všetky vydané verzie QGIS je možné stiahnuť na 

stránke https://qgis.org/downloads/. Návod pre staršie verzie QGIS (3.10-3.18) je možné stiahnuť 

tu: https://www.geoportal.sk/files/gz/s-jtsk_jtsk03_v_qgis_v3.pdf 

 

1. Výber súradnicového systému novej vrstvy 
 

Nová vektorová vrstva napr. vo formáte Shapefile sa dá vytvoriť v hlavnom menu v paneli Layer → 

Create Layer → New Shapefile Layer: 

 
Po spustení tejto funkcie sa otvorí okno New Shapefile Layer, kde na výber súradnicového systému 

slúži tlačidlo Select CRS . Po kliknutí na toto tlačidlo sa otvorí okno Coordinate Reference System 
Selector, kde do políčka Filter treba pre súradnicový systém S-JTSK [JTSK03] / Krovak East North 
zadať jeho EPSG kód 8353 alebo prípadne jeho názov, potom v políčku Predefined Coordinate 
Reference Systems nájdený súradnicový systém označiť kliknutím myšou a nakoniec kliknúť na 
tlačidlo OK: 

 

https://qgis.org/en/site/
https://qgis.org/downloads/
https://www.geoportal.sk/files/gz/s-jtsk_jtsk03_v_qgis_v3.pdf
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Súradnicový systém vrstvy je tak zadefinovaný. V okne New Shapefile Layer ešte v políčku File name 

zadať názov a umiestnenie súboru, v políčku Geometry type vybrať typ geometrie objektov (bod, 

línia, polygón), v časti New Field je možné zadefinovať atribúty a nakoniec kliknúť na tlačidlo OK: 

 

Zoznam EPSG kódov ďalších súradnicových systémov používaných na území Slovenska je uvedený 

v tabuľke 2. 

 
 

2. Priradenie súradnicového systému existujúcej vrstve 
 

Keďže súradnicový systém S-JTSK[JTSK03] nebol v starších verziách QGIS zadefinovaný, nedal sa 

údajom priradiť podľa postupu uvedeného v 1. kapitole. Ak je ho potrebné priradiť už existujúcim 

vrstvám vytvorených v tomto súradnicovom systéme napr. pre účely transformácie, je to možné 

urobiť nasledovne: 
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Vektorová vrstva 

Na priradenie súradnicového systému vektorovej vrstve sa používa funkcia Assign projection, ktorá 

sa nachádza v paneli Processing Toolbox→Vector general: 

 
Po spustení tejto funkcie sa otvorí okno Assign projection, kde treba vyplniť potrebné parametre a 

potom kliknúť na tlačidlo Run: 

• Input layer - vybrať vstupnú vrstvu. 

• Assigned CRS - vybrať súradnicový systém. 

• v druhom políčku Assigned CRS zadať názov, formát a umiestnenie výstupného súboru. 

 

Poznámka: Pre súradnicový systém S-JTSK[JTSK] sa používal aj kód ESRI:102067 a môže sa stať,  

že niektoré údaje sú stále uvádzané v súradnicovom systéme s týmto kódom. Aby bolo možné 

v QGIS používať správne transformácie odporúča sa zmeniť súradnicový systém na EPSG:5514: 
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Rastrová vrstva 

Na priradenie súradnicového systému rastrovej vrstve sa používa funkcia Assign projection, ktorá 

sa nachádza v paneli Raster→Projections: 

 

 

 

Po spustení tejto funkcie sa otvorí okno Assign projection, kde treba vyplniť potrebné parametre a 

potom kliknúť na tlačidlo Run: 

• Input layer - vybrať vstupný raster. 

• Desire CRS – vybrať súradnicový systém. 
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3. Transformácie pre súradnicový systém S-JTSK[JTSK03] 
 

Najnovšie verzie aplikácie QGIS (od verzie 3.12.3) plne podporujú transformácie týkajúce sa 

súradnicového systému S-JTSK[JTSK03]. Ich zoznam je uvedený v tabuľke 1. 

                      Tab. 1 Zoznam transformácií pre S-JTSK[JTSK03] 

Vstupný   
súradnicový systém 

Výstupný   
súradnicový systém 

Transformácia 
[EPSG kód] 

S-JTSK (JTSK03) S-JTSK (JTSK) 8364 

S-JTSK (JTSK) S-JTSK (JTSK03) 8364 

S-JTSK (JTSK03) ETRS89 8367 

ETRS89 S-JTSK (JTSK03) 8365 

S-JTSK (JTSK03) WGS84 8368 

WGS84 S-JTSK (JTSK03) 8368 
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Postup pre nastavenie transformácie medzi súradnicovými systémami v aplikácii QGIS 
 

Manuálne nastavenie transformácií 

 

Príklad pre transformáciu z S-JTSK[JTSK03] do S-JTSK[JTSK]: 

V hlavnom menu v paneli Settings→ Options otvoriť záložku Transformations a tam v časti Default 

Datum Transformations kliknúť na tlačidlo  : 

 

Otvorí sa okno Select Datum Transformations, kde v políčku Source CRS vybrať súradnicový systém 

S-JTSK [JTSK03] / Krovak East North (kód EPSG:8353) a v políčku Destination CRS zase  

S-JTSK / Krovak East North (kód EPSG:5514) tak, že po kliknutí na tlačidlo Select CRS  sa otvorí 

okno Coordiante Reference System Selector, kde v políčku Filter zadať EPSG kód alebo prípadne 

názov daného súradnicového systému. Následne sa zobrazia nájdené transformácie, z ktorých treba 

vybrať správnu, políčko Allow fallback transforms if preffered operation fails nechať neoznačené 

a nakoniec kliknúť na tlačidlo OK:  
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Transformácia je tak v paneli Transformations zadefinovaná: 

 
 

Podobným spôsobom nastaviť aj opačnú transformáciu z S-JTSK[JTSK] do S-JTSK[JTSK03] a tiež 

ostatné transformácie medzi súradnicovými systémami používanými na území Slovenska, ktorých 

zoznam je uvedení v tabuľke 2. 
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Tab. 2  Zoznam vybraných súradnicových referenčných systémov používaných na území SR 

Názov v EPSG EPSG kód Názov v QGIS Typ Názov v RTS 

S-JTSK [JTSK03] 8351 S-JTSK [JTSK03] GCS 
Bessel1841-LatLon 

(JTSK03) 

S-JTSK [JTSK03] / Krovak East North 8353 S-JTSK [JTSK03] / Krovak East North PCS S-JTSK (JTSK03) 

S-JTSK 4156 S-JTSK GCS Bessel1841-LatLon (JTSK) 

S-JTSK / Krovak East North 5514 S-JTSK / Krovak East North PCS S-JTSK (JTSK) 

ETRS89 4258 ETRS89 GCS ETRS89-LatLonh 

ETRS89 / UTM zone 33N 3045; 25833 ETRS89 / UTM zone 33N (N-E) PCS ETRS89-TM33 

ETRS89 / UTM zone 34N 3046; 25834 ETRS89 / UTM zone 34N (N-E) PCS ETRS89-TM34 

ETRS89 / LAEA 3035 ETRS89-extended / LAEA Europe PCS ETRS89-LAEA 

ETRS89 / LCC 3034 ETRS89-extended / LCC Europe PCS ETRS89-LCC 

WGS84 4326 WGS 84 GCS - 

WGS84 / Pseudo-Mercator 3857 WGS 84 / Pseudo-Mercator PCS - 

WGS84 / UTM zone 33N 32633 WGS 84 / UTM zone 33N PCS - 

WGS84 / UTM zone 34N 32634 WGS 84 / UTM zone 34N PCS - 

 

Vysvetlivky:  

- GCS – Geographic Coordinate System 

- PCS – Projected Coordinate System 

- RTS – Rezortná transformačná služba 

 

Transformácie pre súradnicový systém S-JTSK[JTSK03] uvedené v tabuľke 1: 

▪ S-JTSK[JTSK03] → S-JTSK[JTSK] 

 

 

▪ S-JTSK[JTSK] → S-JTSK[JTSK03] 

 

 

▪ S-JTSK[JTSK03] → ETRS89 

 
 

 

 

https://zbgis.skgeodesy.sk/rts/sk/Transform
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▪ ETRS89→ S-JTSK[JTSK03] 

 

 

▪ S-JTSK[JTSK03] → WGS84 

 

 

▪ WGS84 → S-JTSK[JTSK03] 

 

 

Automatické nastavenie transformácií 

Pre automatické nastavenie správnych transformácií je možné použiť súbor QGIS3.txt, ktorý je 

možné stiahnuť z nasledujúceho odkazu https://www.geoportal.sk/files/qgis/qgis_trans_proj8.zip. 

Súbor QGIS3.txt obsahuje zadefinované transformácie medzi súradnicovými systémami z tabuľky 2. 

Kompletný zoznam zadefinovaných transformácii je uvedený v tabuľke 3. Obsah tohto súboru stačí 

nakopírovať do časti Projections konfiguračného súboru QGIS3.ini, ktorý sa nachádza v priečinku 

C:\Users\user_name\AppData\Roaming\QGIS\QGIS3\profiles\default\QGIS\ . 

V operačnom systéme Windows môže byť priečinok AppData skrytý. Zobrazovanie skrytých 

priečinkov je možné nastaviť cez Ovládací panel → Možnosti Prieskumníka → Zobrazenie → 

Súbory a priečinky → Skryté súbory a priečinky a tam zvoliť možnosť Zobrazovať skryté súbory, 

priečinky a jednotky. 

Súbor QGIS3.ini je možné otvoriť v textovom editore napr. Notepad++, WordPad a pod.: 

 

https://www.geoportal.sk/files/qgis/qgis_trans_proj8.zip
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Transformácie sú následne automaticky nastavené v paneli Settings → Options → Transformations 

v časti Deafault Datum Transformations: 

 

          Tab. 3  Zoznam transformácii zadefinovaných v súbore QGIS3.txt 

Vstupný   
súradnicový systém 

Kód EPSG 
Výstupný   

súradnicový systém 
Kód EPSG 

S-JTSK [JTSK03] / Krovak East North 8353 S-JTSK / Krovak East North 5514 

S-JTSK / Krovak East North 5514 S-JTSK [JTSK03] / Krovak East North 8353 

S-JTSK [JTSK03] / Krovak East North 8353 ETRS89 4258 

ETRS89 4258 S-JTSK [JTSK03] / Krovak East North 8353 

S-JTSK [JTSK03] / Krovak East North 8353 ETRS89 / UTM zone 33N 3045; 25833 

ETRS89 / UTM zone 33N 3045; 25833 S-JTSK [JTSK03] / Krovak East North 8353 

S-JTSK [JTSK03] / Krovak East North 8353 ETRS89 / UTM zone 34N 3046; 25834 

ETRS89 / UTM zone 34N 3046; 25834 S-JTSK [JTSK03] / Krovak East North 8353 

S-JTSK [JTSK03] / Krovak East North 8353 ETRS89 / LCC 3034 

ETRS89 / LCC 3034 S-JTSK [JTSK03] / Krovak East North 8353 

S-JTSK [JTSK03] / Krovak East North 8353 ETRS89 / LAEA 3035 

ETRS89 / LAEA 3035 S-JTSK [JTSK03] / Krovak East North 8353 

S-JTSK [JTSK03] / Krovak East North 8353 WGS84 4326 

WGS84 4326 S-JTSK [JTSK03] / Krovak East North 8353 

S-JTSK [JTSK03] / Krovak East North 8353 WGS 84 / Pseudo-Mercator 3857 

WGS 84 / Pseudo-Mercator 3857 S-JTSK [JTSK03] / Krovak East North 8353 

S-JTSK [JTSK03] / Krovak East North 8353 WGS 84 / UTM zone 33N 32633 

WGS 84 / UTM zone 33N 32633 S-JTSK [JTSK03] / Krovak East North 8353 

S-JTSK [JTSK03] / Krovak East North 8353 WGS 84 / UTM zone 34N 32634 

WGS 84 / UTM zone 34N 32634 S-JTSK [JTSK03] / Krovak East North 8353 

S-JTSK / Krovak East North 5514 ETRS89 4258 

ETRS89 4258 S-JTSK / Krovak East North 5514 
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S-JTSK / Krovak East North 5514 ETRS89 / UTM zone 33N 3045; 25833 

ETRS89 / UTM zone 33N 3045; 25833 S-JTSK / Krovak East North 5514 

S-JTSK / Krovak East North 5514 ETRS89 / UTM zone 34N 3046; 25834 

ETRS89 / UTM zone 34N 3046; 25834 S-JTSK / Krovak East North 5514 

S-JTSK / Krovak East North 5514 ETRS89 / LCC 3034 

ETRS89 / LCC 3034 S-JTSK / Krovak East North 5514 

S-JTSK / Krovak East North 5514 ETRS89 / LAEA 3035 

ETRS89 / LAEA 3035 S-JTSK / Krovak East North 5514 

S-JTSK / Krovak East North 5514 WGS84 4326 

WGS84 4326 S-JTSK / Krovak East North 5514 

S-JTSK / Krovak East North 5514 WGS 84 / Pseudo-Mercator 3857 

WGS 84 / Pseudo-Mercator 3857 S-JTSK / Krovak East North 5514 

S-JTSK / Krovak East North 5514 WGS 84 / UTM zone 33N 32633 

WGS 84 / UTM zone 33N 32633 S-JTSK / Krovak East North 5514 

S-JTSK / Krovak East North 5514 WGS 84 / UTM zone 34N 32634 

WGS 84 / UTM zone 34N 32634 S-JTSK / Krovak East North 5514 

ETRS89 4258 WGS84 4326 

WGS84 4326 ETRS89 4258 

 

Poznámka: 
Na území Slovenska sa súradnicový systém WGS84 považuje za identický s ETRS89. Z toho dôvodu 

sa pri transformácii z S-JTSK [JTSK03] do ETRS89 aj WGS84 a späť používajú rovnaké transformačné 

parametre. 

V súbore QGIS3.txt sú zadefinované aj presné transformácie zo súradnicového systému                    

S-JTSK[JTSK] (EPSG:5514) do WGS84 (EPSG:4326) a späť s využitím medzikroku s transformáciou  

do S-JTSK[JTSK03]. Bez použitia súboru QGIS.txt sa v aplikácii QGIS tieto transformácie nedajú 

manuálne zvoliť. 

 
 

4. Transformácia súradnicového systému 
 

Vektorová vrstva 

Na transformáciu súradnicového systému vektorových údajov je možné použiť dva spôsoby: 

a) V paneli Layers kliknúť pravým tlačidlom myši na vrstvu, vybrať Export a tam Save Feature As...: 
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Otvorí sa okno Save Vector Layer as..., kde treba vyplniť potrebné parametre a potom kliknúť na 

tlačidlo OK: 

• Format - vybrať formát výstupného súboru. 

• File name - zadať názov a umiestnenie výstupného súboru. 

• CRS - vybrať výstupný súradnicový systém. 

 

b) V hlavom menu kliknúť na panel Vector → Data Management Tools → Reproject layer: 

 
 

Otvorí sa okno Reproject layer, kde treba vyplniť potrebné parametre a potom kliknúť na tlačidlo 

Run:  

• Input layer - vybrať vstupnú vrstvu. 

• Target CRS - vybrať výstupný súradnicový systém. 

• Advanced parameters – skontrolovať nastavenú transformáciu (z ponúkaných možností 

vybrať správnu). 

• Reprojected - zadať názov, formát a umiestenie výstupného súboru. 
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Poznámka: Keďže funkcia Reproject layer je rozšírená o parameter Advanced parameters, kde treba 

manuálne vybrať z ponúkaných možností správnu transformáciu, je výhodnejšie pre transformáciu 

vektorových údajov použiť funkciu Save Features As popísanú v časti a), kde aplikácia automaticky 

používa transformácie zadefinované v paneli Settings → Options → Transformations.  
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Rastrová vrstva 

Na transformáciu súradnicového systému rastrových údajov je možné použiť dva spôsoby: 

a)  V paneli Layers kliknúť pravým tlačidlom myši na vrstvu, vybrať Export a tam Save As...: 

 

Otvorí sa okno Save Raster Layer as..., kde treba vyplniť potrebné parametre a potom kliknúť  

na tlačidlo OK: 

• Format - vybrať formát výstupného súboru. 

• File name - zadať názov a umiestnenie výstupného súboru. 

• CRS - vybrať výstupný súradnicový systém. 

• Resolution – zadefinovať rozlíšenie (veľkosť bunky) pretransformovaného rastra (voliteľný 

parameter - ak sa nevyplní, aplikácia si sama vypočíta hodnotu). 
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b)  Funkcia Warp (reproject), ktorá sa nachádza v paneli Raster → Projections: 

 
 

Po spustení tejto funkcie sa otvorí okno Warp (reproject), kde treba vyplniť potrebné parametre a 

potom kliknúť na tlačidlo Run:  

• Input layer - vybrať vstupný raster. 

• Source CRS - vybrať vstupný súradnicový systém. 

• Target CRS - vybrať výstupný súradnicový systém. 

• Resampling method to use - zvoliť metódu pre resampling (prevzorkovanie) rastra. 

• Output file resolution in target georeferenced units – zadefinovať rozlíšenie (veľkosť bunky) 

pretransformovaného rastra (voliteľný parameter - ak sa nevyplní, aplikácia si sama 

vypočíta hodnotu). 

• Output data type – vybrať možnosť Use Input Layer Data Type. 

• Reprojected - zadať názov, umiestnenie a formát výstupného súboru. 
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5. Transformácia medzi S-JTSK[JTSK] a ETRS89 
 

Pre presnú transformáciu údajov medzi súradnicovými systémami S-JTSK[JTSK] a ETRS89 treba  

v paneli Settings → Options → Transformations v časti Default Datum Transformations vybrať 

správnu transformáciu (podľa postupu uvedeného v 3. kapitole): 

 

Transformácia z S-JTSK[JTSK] do ETRS89 (kód EPSG:8443): 

 

Transformácia z ETRS89 do S-JTSK[JTSK] (kód EPSG:8442): 

 


