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Návod na prácu s ortofotomozaikou v aplikácii QGIS 

 

Ortofotomozaiku Slovenskej republiky poskytovanú Geodetickým a kartografickým ústavom 

Bratislava je možné bezodplatne stiahnuť) z cloudu po častiach (západ, stred, východ) alebo 

v menšom rozsahu (do 20 ortosnímok)  vyexportovať z aplikácie Mapový klient ZBGIS v rastrovom 

formáte TIFF+TFW a v súradnicovom systéme S-JTSK[JTSK] (kód EPSG:5514). 

Viac informácií nájdete na stránke www.geoportal.sk v časti „ZBGIS a ŠMD - Ortofotomozaika“.  

Návod bol robený v QGIS verzia 3.18.3-1 (15.5.2021), ktorú je možné spolu s ostatnými verziami 

bezodplatne stiahnuť na stránke https://qgis.org/downloads/. 

Užívateľská príručka anglickom jazyku:  

 QGIS verzia 3.16: https://docs.qgis.org/3.16/en/docs/index.html 

Upozornenie: Názvy priečinkov a súborov, ktoré sa v budú v aplikácii používať, by mali byť 

pomenované bez diakritiky a medzier, pretože niektoré nástroje s tým môžu mať problém. 

 

 

1. Pridanie do projektu a nastavenie súradnicového systému 
 

Na pridanie rastrov ortofotomozaiky do aplikácie QGIS treba v hlavnom menu kliknúť na panel 

Layer→ Add Layer  a tam vybrať funkciu Add Raster Layer: 

 

 
 
 
 
 
 
 
 

https://zbgis.skgeodesy.sk/mkzbgis?bm=zbgis&z=8&c=19.530000,48.800000#/export
http://www.geoportal.sk/
https://www.geoportal.sk/sk/udaje/ortofotomozaika/
https://qgis.org/downloads/
https://docs.qgis.org/3.16/en/docs/index.html
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Otvorí sa okno Data Sorce Manager| Raster, kde v časti Source Type vybrať File, v časti Source kliknúť 

na tlačidlo   (Browse), vybrať požadovaný raster/rastre a potom kliknúť na tlačidlo Add: 

 

 

Následné sa raster pridá do panelu Layers a zobrazí v mapovom okne. Pre presné priblíženie 

v mapovom okne kliknúť pravým tlačidlom myši na vrstvu rastra a vybrať funkciu Zoom to Layer(s): 
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Po pridaní do projektu skontrolovať nastavený súradnicový systém rastra. V paneli Layers kliknúť 

pravým tlačidlom myši na vrstvu a vybrať Properties: 

 

V časti Source v políčku Assign Coordinate Reference System (CRS) je uvedený súradnicový systém 

rastra. Môže sa stať, že po pripojení rastra tam bude hodnota invalid projection z dôvodu, že 

aplikácia nevie presne rozoznať zadefinovaný súradnicový systém. Pre správne polohové 

zobrazovanie rastra spolu s inými vrstvami je potrebné, aby tam bol nastavený správny súradnicový 

systém, čiže S-JTSK[JTSK] s kódom EPSG:5514: 
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Nastavenie správneho súradnicového systému je možné vykonať po kliknutí na tlačidlo  (Select 

CRS). Otvorí sa okno Coordinate Reference System Selector, kde do políčka Filter zadať číslo 5514, 

ktorý predstavuje EPSG kód pre S-JTSK / Krovak East North. Vyhľadaný súradnicový systém sa 

zobrazí v okne Coordinate Reference System, kde ho treba označiť ľavým tlačidlom myši a potom 

kliknúť na tlačidlo OK: 

 
Nakoniec ešte v okne Source kliknúť na tlačidlá Apply a OK. 

 

Raster má tak v projekte nastavený správny súradnicový systém. Po odstránení z projektu sa ale 

takéto nastavenie súradnicového systému rastra neuchová. Pre trvalé priradenie súradnicového 

systému treba použiť funkciu Assign projection, ktorá sa nachádza v hlavnom menu v paneli 

Raster→Projections: 
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Otvorí sa okno Assign projection, kde v časti Input layer vybrať raster ortofotomozaiky a v časti 

Desire CRS vybrať S-JTSK / Krovak East North s kódom EPSG:5514 a kliknúť na tlačidlo Run: 

 
Súradnicový systém rastra je tak zadefinovaný 

 

Súradnicový systém projektu, v ktorom sa budú zobrazovať všetky pridané vrstvy, je možné nastaviť 

v ľavej dolnej časti mapového okna aplikácie po kliknutí na tlačidlo  (Current CRS): 
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Poznámka: Informácie o správnom nastavení súradnicových systémov a transformácií používaných 

na území Slovenska sú uvedené v návode Súradnicový systém S-JTSK[JTSK03] v QGIS  

(https://www.geoportal.sk/files/gz/s-jtsk_jtsk03_v_qgis.pdf). 

 

Ak je do projektu pripojených viacero rastrov ortofotomozaiky je výhodné v paneli Layers vytvoriť 

skupinu Group po kliknutí na tlačidlo  (Add Group) a všetky rastre do nej premiestniť. Bude tak 

možné naraz vypínať a zapínať zobrazenie všetkých rastrov v mapovom okne: 

 

https://www.geoportal.sk/files/gz/s-jtsk_jtsk03_v_qgis.pdf
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2. Nastavenie zobrazenia a symboliky 
 

Ak je potrebné upraviť farebné zobrazenie (jas, kontrast,...) rastra ortofotomozaiky, tak je to možné 

urobiť v Properties (nastaveniach) vrstvy rastra v časti Symbology, kde v časti Color Rendering 

nastaviť a upraviť hodnoty napr.: 

 Brightness (jas), 

 Contrast (kontrast), 

 Saturation (sýtosť), 

 Gamma, 

 Grayscale (zobrazenie v odtieňoch sivej), 

 Hue (farebný odtieň). 

 

V časti Resampling je možné vybrať metódu pre resampling (prevzorkovanie) pri približovaní  

(Zoomed in) alebo odďaľovaní sa  (Zoomed out) na raster v mapovom okne. Aby bol obraz vyhladený, 

treba použiť metódu Bilinear alebo Cubic. Pri parametri Oversampling nastaviť hodnotu minimálne 

2,00: 
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Porovnanie zobrazenia obrazu pri nastavenej metóde resampling: 

 Nearest neighbour: 

 
 
 

 Bilinear: 
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V prípade 4-kanálových RGBN (červené (R), zelené (G), modré (B), blízke infračervené pásmo (NIR)) 

ortosnímok je možné v časti Band Rendering vybrať, ktoré farebné pásma sa majú zobrazovať  

(NIR pásmo je označené ako Band 4). Príklad zobrazenia vo farebnom variante NIR+R+G: 

 Render type = Multiband color 

 Red band = Band 4 

 Green band = Band 1 (Red) 

 Blue band = Band 2 (Green) 

 

Zobrazenie ortosnímky vo farebnom variante NIR+R+G: 
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Nastavenie priehľadnosti rastra je možné urobiť v časti Transparency v parametri Global Opacity: 

 

Porovnanie zobrazenia rastrov, kde ľavý raster má nastavenú hodnotu priehľadnosti  

Global Opacity = 60%. 

 

 

3. Vytvorenie rastrových pyramíd 

 

Rastrové vrstvy s veľkým rozlíšením môžu spomaľovať prácu v aplikácii. Vytváraním kópií rastrových 

údajov (tzv. „pyramíd“) s nižším rozlíšením je možné zlepšiť výkon a rýchlosť zobrazovania, pretože 

aplikácia potom vyberá najvhodnejšie rozlíšenie na použitie v závislosti od úrovne priblíženia 

v mapovom okne. Rastrové pyramídy je možné vytvoriť v Properties (nastaveniach) vrstvy rastra 

v časti Pyramids, kde treba vyplniť potrebné parametre a kliknúť na tlačidlá Build Pyramids a potom 

OK: 

 Overview format - External (pyramídy budú v tomto prípade vytvorené v adresári 

pôvodného rastra s rovnakým názvom a príponou .ovr). 

 Resampling method - vybrať metódu pre resampling (prevzorkovanie), ktorá bude použitá 

pri tvorbe rastrových pyramíd (napr. Bilinear). 
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 Resolutions - z ponuky vybrať kliknutím požadované rozlíšenia, pre ktoré sa vytvoria 

jednotlivé úrovne pyramídy. 

 

 

Po ukončení procesu sa v adresári s rastrom ortofotomozaiky vytvoria pyramídy do súboru 

s príponou .ovr: 

 
 

Poznámka: Pre vytváranie rastrových pyramíd treba mať povolenie na zápis do adresára, kde sú 

uložené rastre ortofotomozaiky. 
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4. Odstránenie alebo vyexportovanie NIR pásma pri ortofotomozaike vo variante RGBN 

 
1. Odstránenie NIR pásma z RGBN rastra 

V prípade potreby je pri farebných 4-kanálových rastrov ortofotomozaiky vo variante RGBN možné 

odstrániť NIR (blízke infračervené) pásmo pomocou nástroja Rearrange bands, ktorý sa nachádza 

v paneli Processing Toolbox→GDAL→Raster conversion: 

 

Po spustení nástroja treba vyplniť potrebné parametre a potom kliknúť na tlačidlo Run: 

 Input Layers – vybrať vstupný raster. 

 Selected band(s) – vybrať farebné pásma, ktoré bude obsahovať výstupný raster: Band 1 

(Red), Band 2 (Green), Band 3 (Blue). 

 Profile – vybrať typ kompresie údajov JPEG Compression a v políčku Value zadať kvalitu 

kompresie v % (napr. 90%), od ktorej bude závisieť aj veľkosť a obrazová kvalita výstupného 

rastra. 

 Output data type - vybrať možnosť Use Input Layer Data Type. 

 Convertd - zvoliť možnosť Save to File a zadať názov, formát (napr. TIF files) a umiestnenie 

výstupného rastra. 
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Na výstupe tak bude raster v klasickom farebnom variante RGB. Takto upravenú ortofotomozaiku je 
následné možné použiť v aplikáciách, ktoré nepodporujú zobrazovanie 4-kanálových RGBN rastrov  
(napr. Kokeš alebo Bentley MicroStation). 
Týmto spôsobom je z rastra taktiež možné odstrániť aj iné farebné pásmo (R, G alebo B). 
 
 
2. Vyexportovanie NIR pásma z RGBN rastra 

V prípade potreby je pri farebných 4-kanálových rastrov ortofotomozaiky vo variante RGBN možné 

pomocou nástroja Rearrange bands vybrať len NIR (blízke infračervené) pásmo a vyexporotvať ho 

do nového rastra, kde sa v tomto prípade pri parametri Selected band(s) vyberie len NIR pásmo 

(Band 4): 
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Na výstupe tak bude 1-kanálový raster obsahujúci len NIR pásmo.  
Jeho zobrazenie v aplikácii: 

 
Týmto spôsobom je z rastra možné vybrať a vyexportovať aj iné farebné pásmo (R, G alebo B). 

 
 

5. Spojenie rastrov 
 

Spojenie viacerých rastrov ortosnímok do jedného súvislého rastra je možné pomocou nástroja 

Merge, ktorý sa nachádza v paneli Processing Toolbox → GDAL→ Raster miscellaneous: 
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Po spustení nástroja treba vyplniť potrebné parametre a kliknúť na tlačidlo Run: 

 Input Layers – vybrať vstupné rastre. 

 Output data type - vybrať možnosť Byte. 

 Profile – vybrať typ kompresie údajov JPEG Compression a v políčku Value zadať kvalitu 

kompresie v % (napr. 90%), od ktorej bude závisieť aj veľkosť a obrazová kvalita výstupného 

rastra. 

 Merged - zvoliť možnosť Save to File a zadať názov, formát (napr. TIF files) a umiestnenie 

výstupného rastra. 

 

Výsledný spojený raster ortofotomozaiky zložený zo štyroch ortosnímok: 
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Poznámka: Tento postup pre spájanie rastrov s využitím nástroja Merge je vhodný pre rastre vo 

farebnom variante RGB. Postup pre odstránenie NIR pásma z RGBN rastrov je uvedený 

v 4. kapitole. 

 

6. Vytvorenie výrezu 

 
Výrez z ortofotomozaiky podľa zvoleného územia (polygónu) je možné urobiť pomocou nástroja  

Clip raster by mask layer, ktorý sa nachádza v paneli Raster→Extraction: 

 
 

Po spustení toho nástroja treba vyplniť požadované parametre a potom kliknúť na tlačidlo Run: 

 Input layer - vybrať vstupný raster. 

 Mask layer - vybrať vektorovú vrstvu, podľa ktorej sa vytvorí výrez z ortofotomozaiky. 

 Source CRS – vybrať súradnicový systém vstupného rastra. 

 Target CRS – vybrať súradnicový systém výstupného rastra. 

 Match the extent of the clipped raster to the extent of the mask layer – označiť políčko. 

 Clipped (mask) - zvoliť možnosť Save to File a zadať názov, formát (napr. TIF files)  

a umiestnenie výstupného rastra. 
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Ukážka územia, podľa ktorého sa má z ortofotomozaiky urobiť výrez: 
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Výsledný orezaný raster: 

 

 

7. Určenie presného dátumu leteckého snímkovania 

 
Ak je potrebné zistiť presný dátum, kedy v danej lokalite prebiehalo letecké snímkovanie a pre ktorý 

je obsah na ortofotomozaike aktuálny, je treba použiť prehľady leteckých meračských snímok (LMS), 

z ktorých bola Ortofotomozaika SR vyhotovená (1. alebo 2. cyklus). Je ich možné stiahnuť vo formáte 

ESRI Shapefile na stránke www.geoportal.sk v časti „Ortofotomozaika“. 

Pre pridanie vektorovej vrstvy prehľadov LMS treba v hlavnom menu kliknúť na panel 

 Layer→ Add Layer  a tam vybrať funkciu Add Vector Layer: 

 

 

 

 

 

 

 

 

 

http://www.geoportal.sk/
https://www.geoportal.sk/sk/udaje/ortofotomozaika/
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Otvorí sa okno Data Sorce Manager| Vector, kde v časti Source Type vybrať File, v časti Source kliknúť 

na tlačidlo   (Browse) a vybrať súbor Shapefile s príponou .shp a potom kliknúť na tlačidlo Add: 

 

Vrstva s prehľadom LMS je tak pridaná do projektu. V paneli Layers ju umiestniť nad pridané rastre 

ortofotomozaiky: 

 

Atribútovú tabuľku je možné otvoriť po kliknutí pravým tlačidlom myši na vrstvu a vybratí Open 

Atttribute Table: 

 



22 
 

V tabuľke je v stĺpci Datum uvedený dátum, kedy bola LMS vyhotovená: 

 

Pre úpravu symboliky vrstvy prehľadov LMS kliknúť pravým tlačidlom myši na vrstvu, vybrať 

Properties→Symbology, kde nastaviť požadované parametre a kliknúť na tlačidlá Apply a OK: 

 Single Symbol. 

 Fill - Simple Line. 

 Symbol layer type - Outline: Simple Line. 

 Color - vybrať farbu. 

 Stroke width - vybrať hrúbku línie. 

 Stroke style - vybrať typ línie (Solid line). 
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Popis jednotlivých polygónov so zobrazením dátumu snímkovania je možné nastaviť  

v Properties→Labels, kde nastaviť požadované parametre a kliknúť na tlačidlá Apply a OK: 

 Single Labels. 

 Value – vybrať atribút Datum. 

 Text→Font – vybrať typ (font) písma. 

 Text→Style – vybrať štýl písma. 

 Text→Size – vybrať veľkosť písma. 

 Text→Color – vybrať farbu písma. 
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Výsledné zobrazenie ortofotomozaiky spolu s prehľadom hraníc LMS a dátumov ich vyhotovenia: 

 

 

8. Transformácia do iného súradnicového referenčného systému 

 
Informácie o správnom nastavení súradnicových systémov a transformácií používaných na území 

Slovenska sú uvedené v návode Súradnicový systém S-JTSK[JTSK03] v QGIS  

(https://www.geoportal.sk/files/gz/s-jtsk_jtsk03_v_qgis.pdf). 

Na transformáciu polohového súradnicového systému rastrových údajov je možné použiť nástroj 
Warp (reproject), ktorý sa nachádza v paneli Raster → Projections: 

 
 
 
 
 
 
 
 

https://www.geoportal.sk/files/gz/s-jtsk_jtsk03_v_qgis.pdf
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Po spustení tejto funkcie sa otvorí okno Warp (reproject), kde treba vyplniť potrebné parametre  

a potom kliknúť na tlačidlo Run:  

 Input layer - vybrať vstupný raster. 

 Source CRS - vybrať vstupný súradnicový systém. 

 Target CRS - vybrať výstupný súradnicový systém. 

 Resampling method to use - zvoliť metódu pre resampling (prevzorkovanie) rastra  

(napr. Nearest Neighbour). 

 Output file resolution in target georeferenced units – zadefinovať rozlíšenie (veľkosť bunky) 

pretransformovaného rastra (voliteľný parameter - ak sa nevyplní, aplikácia si sama 

vypočíta hodnotu podľa rozlíšenia vstupného rastra). 

 Profile -  vybrať typ kompresie údajov JPEG Compression a v políčku Value zadať kvalitu 

kompresie v % (napr. 90%), od ktorej bude závisieť aj veľkosť a obrazová kvalita výstupného 

rastra. 

 Output data type – vybrať možnosť Use Input Layer Data Type. 

 Reprojected - zadať názov, umiestnenie a formát výstupného súboru 
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Poznámka: Ak je potrebné pretransformovať viacero ortosnímok, ktoré spolu susedia, tak 

na začiatku tieto rastre spojiť do jedného podľa postupu uvedeného v 5. kapitole 

a pretransformovať tento spojitý raster. Ak by sa ortosnímky transformovali po jednej, tak 

pretransformované rastre potom nemusia na stykoch presne sedieť. 

 

9. Pripojenie webových mapových služieb 
 

Ortofotomozaika SR je taktiež dostupná na prehliadanie prostredníctvom OGC webových mapových 

služieb WMS (Web Map Service) a WMTS (Web Map Tile Service). 

URL adresy pre pripojenie služieb je možné nájsť na stránke www.geoportal.sk v časti „SLUŽBY“: 

Služba URL 

WMS https://zbgisws.skgeodesy.sk/zbgis_ortofoto_wms/service.svc/get 

WMTS https://zbgisws.skgeodesy.sk/zbgis_ortofoto_wmts/service.svc/get 

 

Na pridanie WMS služieb do aplikácie QGIS treba v hlavnom menu kliknúť na panel  

Layer→ Add Layer  a tam vybrať funkciu Add WMS/WMTS Layer: 

 

Presný postup pre pripojenie a prácu s webovými mapovými službami je uvedený v Návode na 

prácu s WMS a WMTS v QGIS, ktorý je možné stiahnuť stiahnuť tu: 

https://www.geoportal.sk/files/sluzby/wms_navody/navod_wms_wmts_qgis.pdf. 

Ukážka pripojenej WMTS služby v aplikácii QGIS: 

 

https://www.ogc.org/standards/wms
https://www.ogc.org/standards/wmts
http://www.geoportal.sk/
https://www.geoportal.sk/sk/sluzby/mapove-sluzby/mapove-sluzby.html
https://www.geoportal.sk/files/sluzby/wms_navody/navod_wms_wmts_qgis.pdf

